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Læs mere om...

En film kan sættes sammen af flere enkeltscener. Hvis ikke du 
tilføjer nogen programering, vil scenerne blive afspillet i den ræk-
kefølge de optræder på listen i paletten Scene. 

Den store fordel ved at opdele filmen i flere scener er, at Timeline 
på denne måde bliver langt mere overskuelig. Scenerne navngives 
ved at dobbeltklikke på navnet, og de kan flyttes op og ned i listen 
ved hjælp af musen.

Flere scener
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Opgave

Opgavebeskrivelse

Opgaven består i at tilføje flere scener til en film, der i forvejen er 
opbygget af flere scener. Du skal lave en fortsættelse af den lille 
film med den uheldige sprængningsekspert. Byg videre på histo-
rien ved at tilføje et par scener.

•	 Åbn filmen scener.fla som ligger i kursusmaterialet. 
Du kan se filmen ved at vælge Ctrl+Enter. Kigger du på .fla 
filen, kan du se, hvordan den er lavet. Filen er inddelt i scener, 
der har fået navne efter, hvad der sker på scenen.

Aflevér opgaven som aftalt med din underviser.

Du kan bruge grafikken, 
der ligger som symboler 
i Library, og du kan også 
selv tilføje mere. 
Manden (gomand) er et 
Movie Clip, fordi det er en 
lille film i sig selv - man-
den bevæger sig.
Den sidste scene i fimen 
er ”To be continued”. De 
scener, du indsætter, skal 
du sætte ind foran denne, 
således den forbliver sid-
ste scene. 
Paletten Scene, findes her:
Window > Other panels > 
Scene.
En enkelt scene afspilles 
med alt+enter

Tilføj ny scene

Flere scener
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Læs mere...

At styre scener

Hvis du vælger at bygge din film op af af flere scener, vil filmen 
uden programmering afspille scenerne i den rækkefølge, de står 
i i paletten Scene. Hvis du i stedet ønsker, at brugeren selv skal 
kunne vælge, i hvilken rækkefølge scenerne skal vises, skal der 
et ActionScript til. Scriptet til opgaven ses her. Filmen består af 4 
scener. På alle scener er der knapper, der kan føre til en af de an-
dre scener. Her er et eksempel på et script til en scene med knap-
per. Det kan se voldsomt ud, men det er ikke så galt, da det er det 
samme script, der gentages for hver knap.
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Opgave

At styre scener

•	 Markér alle 4 knapper. Klik på To Stage i Align paletten, vælg 
derefter Align Bottom Edge.

•	 Marker de 4 knapper uden teksten, og vælg Space evenly hori-
zontally.

•	 Markér derefter de 4 tekstbokse og vælg igen Space evenly 
horizontally.

Nu sidder knapperne, som de skal, og det er tid til at duplikere sce-
nen. De 3 andre scener skal være magen til, bortset fra at fotoet 
skal udskiftes.
•	 Lav tre duplikater og omdøb dem. Skift billederne ud på Stage.
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Opgave

At styre scener

Alle knapperne skal have et selvstændigt Instance Name. 
Spring: 	 knap1_btn	 knap2_btn	 knap3_btn	 knap4_btn
Summer: 	 knap1a_btn	 knap2a_btn	 knap3a_btn	 knap4a_btn
Autumn: 	 knap1b_btn	 knap2b_btn	 knap3b_btn	 knap4b_btn
Winter: 	 knap1c_btn	 knap2c_btn	 knap3c_btn	 knap4c_btn
 

 

ActionScript
•	 Opret et nyt lag. Kald det actions. Åbn scriptvinduet og kopier 

scriptet ind.
Spring som er den første scene, skal have en StopAction, for at 
hindre filmen i at gå i gang automatisk.

Når du har skrevet dette script, kopierer du det.
•	 Åbn scenen summer.
•	 Opret et nyt lag, kald det actions. Åbn scriptvinduet og kopier 

scriptet ind.
•	 Udskift navnene i scriptet.
•	 Gentag proceduren på de to sidste scener.

Aflevér opgaven som aftalt med din underviser.

Scriptet her hører til sce-
nen spring. Som du kan 
se, er scriptet ensfor alle 
4 knapper (i mellem de 
stiplede linjer), på nær 
navnene.
De steder, der er mar-
keret med gult, skal du 
skifte navn.

Eksempel
Scenen summer: 
Knapperne hedder
knap1a_btn, knap2a_btn 
osv.
function spring bliver til 
spring2
og efter CLICK,
skal der stå spring2
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Læs mere om...

Navigation
Det er muligt at lave færdige websites i Flash. Det kræver en me-
get stor del programmering, og intensivt studie af Action-
Script 3.0. Der er fortalere og kritikere, når det drejer sig om hele 
sites i Flash, og det hænger naturligvis sammen med, at der både 
er ulemper og fordele forbundet med at producere websites på 
denne måde. Her kommer et par andre plusser og minusser. Der 
er sikkert mange flere på begge sider, dette er også religion!

Fordele Ulemper

Flashfiler opfører sig ens i alle 
browsere

Man kan ikke bruge tilbageknap-
pen, hvis sitet består af flere 
sider.

Flashfiler kan skaleres uden 
kvalitetstab

Man kan ofte ikke kopiere tekst 
og billeder

Du kan arbejde med interak-
tivitet, lyd og video i ét værk-
tøj.

Man kan ikke se, hvorvidt man 
har besøgt et link

Søgemaskinerne kan ikke 
indexere rene Flash sites

Se eksempler her
http://www.peterlarsen.dk/
http://www.australian.dk/
http://www.hm.com/dk/
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Opgave

Opgavebeskrivelse

I denne øvelse skal du lave et navigationssystem, hvor brugeren 
kan klikke sig rundt mellem forskellige ”sider”. Her er det simple 
geometriske former: en cirkel, en trekant og en firkant, men det 
kunne være billeder og tekst. Du kan altså fremstille et helt web-
site på denne måde.

•	 Åbn en ny Flash File.
•	 Bevar defaultstørrelsen på Stage, hvid baggrundsfarve.
•	 Tegn en stor firkant med Rectangle Tool. Firkanten skal have en 

rød Stroke og ingen fyldfarve. 
•	 Dobbeltklik på stroken. Konvertér firkanten til et symbol vælg 

F8. Vælg Movie Clip som type og navngiv det indhold. 

•	
•	
•	
•	
•	 Dobbeltklik på stroken, på den måde kommer du over i Mo-

vieclippets eget ”studie”.
•	 Vælg frame 4 i Timeline – højreklik og vælg Insert Frame. 

Navngiv laget indhold.
•	 Opret et nyt lag og kald det grafik.
•	 Markér frame 2 i dette lag og indsæt en Keyframe (F6). Tegn 

herpå en firkant indeni den store firkant.

Navigation
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Opgave

Navigation
•	 Indsæt en Blank Keyframe (F7) i frame 3 og tegn en cirkel in-

deni den store firkant.
•	 Indsæt en Blank Keyframe (F7) i frame 4 og tegn en trekant 

indeni den store firkant.
•	 Opret et nyt lag, kald det labels. Indsæt Keyframes i frame 2, 3 

og 4. 

•	 Frame 2 skal have en label kaldet firkant, frame 3 skal hedde 
cirkel og frame 4 skal hedde trekant, således der er overens-
stemmelse mellem navnene og figurerne.

•	
•	
•	
•	
•	
•	
•	

•	 Vend tilbage til hovedscenen, markér den store firkant, og giv 
den instance navnet geometri_mc.

Knapper
Der skal bruges tre knapper til at styre filmen med. 

•	 Opret et nyt lag, kald det knapper.
•	 Tegn en rektangel til en knap, markér den og konverter den til 

en Button (F8). Navngiv den knap.
•	 Duplikér knappen 2 gange (ctrl+d), placér dem pænt ved siden 

af hinanden ovenover firkanten.
•	 Giv knapperne instance navne; firkant_btn, cirkel_btn og tre-

kant_btn.
•	 Opret et nyt lag, kald det tekst. Skriv de tre tekster til knap-

perne; Firkant, Cirkel og Trekant, placér teksterne på hver sin 
knap.

Tip
Lav en pæn ligesidet 
trekant: 
Vælg Rectangel Tool 
>Polystar Tool. 
Vælg Properties > 
Tool Settings > 
Options > Number of 
Sides: 3. 
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Opgave

Navigation
For at knapperne kan virke, skal der lidt programmering til. Opret et 
nyt lag, kald det Actions. Skriv følgende ActionScript i frame 1:

Den første linie bevirker at Movie Clippet geometri_mc stopper. Hvis 
ikke den var der, ville filmen starte automatisk.

Linie 2 til 5 kaldes en funktion. 

Med addEventListener på linie 6 tilføjes en ”begivenhedslytter”. 
addEventListener lytter efter en begivenhed, her: MouseEvent.CLICK. 
Når begivenheden indtræffer, kaldes funktionen klikfirkant.

Det hele bevirker, at Movie Clippet geometri_mc vil gå til frame fir-
kant, når en bruger trykker på knappen.

Når du har tjekket, at firkant-knappen virker med Test Movie (Ctrl + 
Enter), kan du få de andre knapper til at fungere ved at kopiere ko-
den fra linie 3 til 6. Husk at du selvfølgelig skal udskifte ordet firkant 
med cirkel og trekant.

Aflevér opgaven som aftalt med din underviser.
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Læs mere om...

Der findes i dag mange forskellige billedfremvisere til fri download 
på nettet. Det er glimrende og dem kan man sagtens bruge. Den 
mest udbredet er nok Lightbox. 
Det er i derimod også sjovt at kunne lave nogle selv, og derfor er 
der taget tre opgaver med, hvor jeg viser 3 forskellige metoder 
(Action-Scripts), alt efter hvad gallerierne skal kunne.

Galleri 1: 	 Brugeren kan kun bladre frem til sidste billede og så 	
		  tilbage til første billede.

Galleri 2: 	 Brugeren kan bladre uendeligt, altså starte forfra.

Galleri 3:	 Billederne er ikke en integreret del af filmen, men 
		  loades undervejs, det giver en mindre og derved hur-	
		  tigere fil.

Det er en god idé, uanset hvilken metode du anvender, at angive 
hvor mange billeder galleriet består af. Det er ikke ligegyldigt for 
brugeren, om hun skal se 10 eller 100, i sær ikke hvis det kører 
automatisk. En nem løsning er at tilføje tal på billederne, dette gø-
res f.eks. i Photoshop.

Her viser du, at vi er nået til foto 3 af 6.

Billedgallerier
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Opgave

Opgavebeskrivelse

Du skal lave et billedgalleri, hvor brugeren kan klikke sig igennem 
en stak billeder. På de næste 2 sider er der opgaver med varianter.

•	 Åbn en ny Flash File.
•	 Vælg Import - Import to Library.
•	 Åbn mappen galleri1 fra kursusmaterialet, markér alle 6 billeder 

og vælg Open.
•	 Træk billede 1 over på Stage. 
•	 Markér frame 2 og indsæt et tomt keyframe (F7), træk billede 2 

ind på Stage, placér billedet i samme position som billede 1 ved 
hjælp af Align panelet. Fortsæt samme fremgangsmåde med de 
4 sidste billeder.

•	 Navngiv laget galleri. Afspil filmen, billederne kører i sløjfe 
(loop).

•	 Opret 2 lag. Kald det ene knapper og det andet actions.
•	 Placér to knap-symboler (buttons) på laget, du kaldte knapper. 

Det skal være dem, man klikker på for at bladre frem og tilbage 
i billedsekvensen, det kunne f.eks. være pile. 

•	 De to knapper skal have hver sit Instance-navn: frem_btn og 
tilbage_btn.

•	 I actions-laget i frame 1 skrives først en stop-action. Derefter 
skal der tilføjes en ”eventlistener” til knappen, der lytter på, 
om der bliver klikket på den. Koden til din tilbage-knappen er 
magen til, bortset fra at kommandoen ikke hedder nextFrame() 
men prevFrame().

•	
•	
•	
•	
•	
•	
•	
•	
•	
•	
•	
•	

•	 Prøv derefter at redigere i filmen, således at der ikke er en 
tilbage-knap i første frame, og frem-knappen forsvinder i sidste 
frame.

Aflevér opgaven som aftalt med din underviser.

Billedgalleri 1

Billedgalleri hvor 
man kan bladre 
frem og tilbage
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Opgave

Opgavebeskrivelse

Skal galleriet være en ”evighedsmaskine”, så man kan blive ved 
med at klikke frem eller tilbage, skal koden se således ud:

Her anvendes if og else sætninger = hvis/ellers.
If-sætninger anvendes til at lave en betingelse, som skal
være opfyldt for at indholdet skal udføres. Ellers skal else-sætnin-
gen træde i kraft.
I dette tilfælde læses det således:
hvis indeværende/aktuelle Frame er lig med Frame 6, så gå til og 
stop ved Frame 1

Aflevér opgaven som aftalt med din underviser.

Billedgalleri 2

Billedgalleri hvor 
man kan blive ved 
med at bladre

13



Opgave

Billedgalleri 3
Opgavebeskrivelse

En tredie variant er et billedgalleri, hvor filerne ikke importeres til 
Library i Flash, men ligger udenfor programmet. Det har den for-
del, at filmen fylder mindre.

•	 Åbn en ny Flash File og gem den i mappen billedgalleri i kur-
susmaterialet. Filen skal ligge i samme mappe som billederne.

•	 Opret 3 lag og kald dem; actions, loader og knapper.
•	 Vælg Window > Components.
•	 Markér laget loader og træk et eksemplar af UILoader-kompo-

nenten ind på Stage. Giv det Instance Name loader.
•	 Lav 2 knapper i knap-laget. Det er dem, man klikker på for at 

bladre frem og tilbage i billederne, så det kunne f.eks. være 
pile. 

•	 De to knapper skal have hver sit Instance Name: frem_btn og 
tilbage_btn.

ActionScriptet, der får de 2 knapper til at virke som frem- og til-
bage knapper, skal ligge i frame 1 i actions laget. 
Man kan lave en knap, der kan bladre, ved at lave en variabel, der 
fungerer som tæller:
Her erklæres en variabel ved navn taeller. 
Med :int angiver man at denne variabel kun kan indeholde heltal. 
Det kaldes at ”fasttype” sine variabler.

Aflevér opgaven som aftalt med din underviser.

Billedgalleri hvor 
billederne loades 
efterhånden
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Læs mere om...

Slideshow
Jeg bruger betegnelsen slideshow her med afsæt i tidligere tiders 
lysbilledfremvisninger. Et slideshow kalder jeg altså en samling af 
billeder, der vises efter hinanden. I denne udgave er der ikke inter-
aktivitet tilføjet, brugeren må læne sig tilbage og nyde resultatet. I 
de afsnit der hedder billedgallerier, er der knapper på, og brugeren 
bliver medbestemmende hvad angår afviklingen.
Mange kommercielle hjemmesider har et animeret banner i top-
pen af siden, oftest en annonce. Der kan være anvendt forskellige 
animationsteknikker og nogle bannere er klikbare. En variation kan 
være et slideshow, hvor billederne f.eks fader ind og ud i hinanden, 
det er hvad denne opgave handler om.
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Opgave

Slideshow
Opgavebeskrivelse

I denne opgave skal du lave et banner, der er 750 pixel x 100 pixel. 
Der skal placeres 5 billeder ved siden af hinanden, billederne fader 
langsomt ind og ud, og som en ekstra effekt, kører der henover bil-
lederne nogle halvtransparente streger.

•	 Åbn en ny Flash File.
•	 Sæt størrelsen på Stage til 750 X 100 px. Sort baggrundsfarve.
•	 Vælg Import - Import to Library.
•	 Åbn mappen slides fra kursusmaterialet, markér alle 5 billeder 

og vælg Open.
For at billederne kan fade ind og ud, er det nødvendigt at lave dem 
om til Moveclips. 
•	 Træk slide1.jpg ind på Stage i position 0.00 0.00. 
•	 Omdøb laget til 1.
•	 Højreklik på billedet og vælg Convert to Symbol.
•	 Giv navnet slide1 og vælg Movieclip som Type. 
I Library ses nu både jpg filen, altså billedet du importerede og det 
nye movieclip af samme billede. Du skal gentage proceduren med 
de andre 4 billeder.
•	 Placer billederne efter hinanden på Stage på hvert sit lag.

Her ses de 5 lag i Timeline samt Library med alle filerne
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Opgave

Slideshow
At billederne fader ind og ud, opfattes af Flash som en bevægelse, 
derfor skal du lave en Classic Tween på billederne. For at effek-
ten ikke skal ”hakke”, det vil sige at billedet går fra fuld synlighed 
til usynlighed over 1 frame, skal hver Tween (hvert lag) minimum  
have 3 Keyframes. Princippet er det samme for hvert lag, når du 
har lavet ét, bruger du samme fremgangsmåde på de øvrige lag. 
Derefter flyttes inholdet  på de enkelte lag på Timeline, således at 
alle billederne ikke bliver vist samtidig. I opgaven her starter alle 
billeder med at være usynlige (Alpha 0%), fader ind til fyld synlig-
hed (Alpha 100%), for derefter at forsvinde igen (Alpha 0%). Du 
kan variere både Alpha% og hastigheden på hvert enkelt billede.

•	 Markér lag 1, indsæt et Keyframe i frame 35, og et i frame 70.
•	 Højreklik på frame 1 og vælg Create Classic Tween.
•	 Højreklik på frame 35 og vælg Create Classic Tween.
•	 Markér Frame 1 på lag 1, og klik på slide1 på Stage.
•	 Vælg Properties >Color Effect > Style Alpha > 0%.
•	 Markér Frame 35 på lag 1, og klik på slide1 på Stage.
•	 Vælg Properties >Color Effect > Style Alpha > 100%.
•	 Markér Frame 70 på lag 1, og klik på slide1 på Stage.
•	 Vælg Properties >Color Effect > Style Alpha > 0%.
•	
•	
•	
•	
•	
•	
•	

•	 Gentag dette på de øvrige 4 lag. Hvis du afspiller filmen nu, vil 
alle billederne blive vist og fade på samme tidspunkt.

•	
•	
•	
•	
•	
•	
•	
•	
•	

For at skabe lidt mere dynamik, kan du flytte på de enkelte Tweens 
i Timeline.
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Opgave

Slideshow
•	 Markér alle frames i lag 2 og flyt dem f.eks til frame 20. Flyt 

også på de andre lag, afspil og flyt rundt indtil du er tilfreds.

Som en ekstra effekt kan der tilføjes et par streger der kører hen-
over billederne. Stregerne laves med Rectangel Tool, gives hvid 
farve, ingen kontur og laves delvis transparente, f.eks Alpha 15%. 
Derefter er det samme fremgangsmåde som med billederne.  
Stregerne kan køre forlæns og baglæns, hurtigt eller langsomt, der 
kan være mange eller få - det er op til dig.

De to streger.

Aflevér opgaven som aftalt med din underviser.
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Læs mere om...

Masker
Ved hjælp af masker kan du styre visningen af et element. Et 
eksempel kan være en undersskrift der kommer til syne, som om 
den bliver skrevet, imens man ser filmen.
Ligesom ved et Motion Guide lag, består en maske af 2 ting: Selve 
masken og det lag, der skal påvirkes af masken. Princippet er at 
masken, som er et elemnet, f.eks. en firkant, bevæger sig henover 
laget med teksten med en almindelig Classic Tween. I Flash ses 
masken som en figur med farve, mens den i browseren bliver gen-
nemsigtig. Det er en ret enkel teknik, men man kan lave mange 
sjove ting med masker. 
En maske kan også følge en Classic Motion Guide.
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Opgave

Opgavebeskrivelse

I denne opgave skal du lave lave en film, der viser en underskrift, 
der bliver skrevet ”live”.

•	 Åbn en ny Flash File.
•	 Sæt størrelsen på Stage til 200 x 100 px. Hvid baggrundsfarve.
•	 Opret 2 lag - et lag der hedder signatur og et lag der hedder 

maske.
•	 �Skriv en tekst med en skriveskrift på laget signatur. 
•	 Indsæt en Keyframe i frame 40 (F6).
•	 Tegn en firkant uden ramme på laget, der hedder maske. Fir-

kanten skal være så stor, at den kan dække hele teksten.
•	 Frame 1: Placér firkanten til venstre for teksten, uden for Sta-

ge. Indsæt en Keyframe i frame 40 (F6) og placér her firkanten 
oven på teksten, så denne er dækket af firkanten.

•	 Vælg Classic Motion Tween.

•	 Højreklik på laget masken (på selve navnet), og vælg Mask fra 
rullemenuen. Laget bliver til en maske, og de to lag knyttes 
sammen. 

•	
•	
•	

Lagene er som udgangspunkt låst. For at låse dem op, skal du 
klikke på hångelåsen ud for hvert lag. Først når lagene er låst op 
vil indholdet komme til syne igen på Stage.

Masker
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Opgave

Masker

I frame 40 skal teksten være helt dækket af masken, da masken i 
browseren åbner for det bagvedliggende.

•	 Indsæt en Stopaction i frame 40, underskriften skal jo kun 
”skrives” én gang.

Aflevér opgaven som aftalt med din underviser.
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Læs mere om...

Scrollbar
Flashfilm er ofte meget visuelle, de består for det meste overve-
jende af grafik, video og billeder og meget lidt tekst. Hvis du gerne 
vil præsentere en længere tekst og ikke ønsker at bruge for meget 
af skærmen, er det en løsning at oprette et mindre tekstfelt og 
herpå sætte en scrollbar.
Tekstfeltet kan du placere, hvor på siden det passer ind, du defi-
nerer selv størrelsen, og scrollbaren kan styles, således den farve-
mæssigt passer til dit design.
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Opgave

Scrollbar
Opgavebeskrivelse

•	 Åbn mappen scroll fra kursusmaterialet, åbn filen tekst til 
scrollbar og kopier teksten.

•	 Åbn en ny Flash File, behold størrelsen på Stage.
•	 Vælg Text tool i Toolbar og foretag følgende indstillinger i Pro-

perties.

•	 Stadig med Text Tool valgt, trækker du en tekstboks på Stage, 
der måler 175 x 175 px.

•	 Vælg Selection Tool i Toolbar og højreklik på tekstboksen, vælg 
Scrollable fra rullemenuen. Nu er tekstboksen låst til den stør-
relse, du angav.

•	 Vælg Text Tool, placér cursoren inde i tekstboksen og indsæt 
teksten, du kopierede fra word filen.

Jeg har vist de 
punkter, du skal 
indstille. Det vig-
tigste er, at du 
får valgt Dyna-
mic Text. Du kan 
naturligvis vælge 
udseende af tek-
sten efter dit eget 
design.
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Opgave

Scrollbar
•	 Tekstboksen bevarer størrelsen. Nederst i højre hjørne ses en 
sort firkant som betyder at tekstboksen er låst.

•	 I menuen Window vælger du Components > User Interfase. 
Vælg USIScrollbar og træk scrollbaren ind på Stage.

•	 Scrollbaren skal hæftes på tekstboksens højre side.
•	
•	
•	
•	
•	
•	
•	
•	
•	
•	
•	
•	

•	 Giv scrollbaren samme højde som tekstboksen. Markér den og 
tilret målene i Properties. 

•	 Markér tekstboksen og giv den navnet tekst_txt i feltet Instan-
ce Name i Properties.
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Opgave

Scrollbar
•	 Markér scrollbaren og vælg Component Inspector Panel i Pro-

perties.

•	 I feltet til højre for scrollTargetName skriver du navnet, du gav 
tekstboksen, i dette eksempel tekst_txt.

•	 Arkivér filmen, se resultatet i en browser (ctrl+enter) og aflevér 
opgaven efter aftale med din underviser.

Styling af scrollbaren
I Library > Component Assets > ScrollBarSkins kan du se alle dele-
ne, scrollbaren består af. Dobbeltklik på dem enkeltvis for at åbne 
dem. De fleste dele er movieclips. For at ændre på farverne skal du 
enten trække henover dem eller dobbeltklikke, således at du får en 
Shape.
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Læs mere om...

Formater
Du kan importere samplede lydfiler i følgende formater:
WAV: Lydformat (Windows)
AIFF: Lydformat (Macintosh)
MP3: MPEG III
Sound Designer II: Kun Macintosh (QuickTime)
Sound Only QuickTime-Film: (QuickTime)
Sun AU: (QuickTime)
System 7-lyd: Kun Macintosh (QuickTime)
De mest almindelige formater er WAV og MP3 

Komprimering
Lyd fylder meget, ofte alt for meget. Det er muligt at komprimere 
de fleste lydfiler med et udmærket resultat. Der er flere forskel-
lige muligheder i Flash, og det bedste, du kan gøre, er at forsøge 
dig frem. Det er muligt, der skal indgås kompromisser. Sådan er 
det ofte med store filer til internettet, både grafik, video og lydfiler, 
men det er for det meste muligt, at spare en hel del datamængde 
og alligevel komme frem til et hæderligt resultat. 
Disse er mulighederne for komprimering:

Lyd - 
import og  
komprimering
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Opgave

Importér lyd
Opgavebeskrivelse

Du skal importere en lydfil og komprimere den. 

•	 Åbn filmen bang.fla fra mappen lyd i kursusmaterialet.
•	 Opret et nyt lag, kald det lyd. 
•	 Vælg Window > Common Libraries > Sounds 

•	 Træk lydfilen xplosion Blast Large 01.mp3 ind på Stage.

Lyden kan ikke ses på Stage, men derimod i laget.

Som andre symboler har lyd også sine egne indstillinger i Proper-
ties. I feltet Name kan der vælges, hvilken lyd fra Library, der skal 
afspilles.

Du skal 
huske at 
vælge 
Stream
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Opgave

I feltet Effect kan der vælges mellem en række forudindstillede 
afspilningseffekter, der kan få lyden til bl.a. at panorere i stereobil-
ledet og fade ud og ind. Klik på blyanten for at åbne redigerings-
vinduet.

Komprimering
•	 Dobbelklik på lydfilen i Library.

•	 Prøv de forskellige kompimeringsformater og komprimerings-
grader. 

OBS. Du ødelægger ikke originalfilen. Komprimeringen bliver først 
tilføjet, når du eksporterer filmen.

Aflevér opgaven som aftalt med din underviser.

Importér lyd

Her er det effekten 
Fade In, der er valgt. 
Man trækker i kurven 
for at styre effek-
ten. I nederste højre 
hjørne er vist en lille 
højtaler. Her kan man 
afspille lyden - man 
behøver altså ikke 
lukke vinduet.

Du kan hurtigt 
teste indstillin-
gerne her.
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Læs mere om...

Afspil lyd
Det kan være meget generende at besøge et website, hvor lyden 
bare buldrer frem, uden at du som bruger har mulighed for at 
stoppe den. Jeg synes der skal være frit valg, ikke alle gider høre 
baggrundsmusik eller være tvangsindlagt til at se videoklip. 
Ved at lave en ganske enkel afspiller, der altså kan stoppe og 
starte lyd, øger du brugervenligheden på dit site.
I Common Library i programmet ligger flere forskellige knapper 
lige til at anvende, men du kan naturligvis også vælge at fremstille 
dine egne.

29



Opgave

Lydafspiller
Opgavebeskrivelse

Du skal fremstille en simpel lydafspiller, der gør det muligt for bru-
geren at tænde og slukke for lyden.

•	 Åbn en ny Flash File.
•	 Sæt størrelsen på Stage til 100 X 50 px. 
•	 Lav selv 2 knapper, eller hent 2 knapper i Window >Common 

Libraries >Bottons.
•	 Markér knapperne og giv dem instance names play_btn og 

stop_btn i Properties.
•	 Opret et nyt lag, kald det lyd.
•	 Træk lyden Foley Footstep Cowboy Boots Running Between 

Surfaces 01.mp3 i Window >Common Libraries >Sounds ind på 
Stage.

•	 Forlæng begge lag til 60 frames.
•	 Flyt lyden til frame 2, frame 1 skal altså være uden lyd.

•	 Opret et nyt lag, kald det actions
•	 Åbn scriptvinduet (f9) og skriv følgende ActionScript:

•	

Scriptet starter med kommandoen stop, da brugeren selv skal 
tænde for lyden. Herefter er der sat en eventlistener ind, som skal 
”høre efter” klik med musen.
Lyden er flyttet til frame 2, den kan ikke ligge i samme frame som 
en stop kommando, så sker der ingenting.

Aflevér opgaven som aftalt med din underviser.
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Læs mere om...

Klikbart banner
Internettet er i dag spækket med annoncer, og langt de fleste af 
disse er fremstillet i Flash. Der er naturligvis forskellige typer, fra 
nogle der ikke er interaktive til meget avancerede, hvor brugeren 
kan spille små spil, høre musik, se video osv.
Du har prøvet at lave knapper tidligere, i den næste øvelse skal 
du fremstille et klikbart banner, hvor hele fladen altså er klikbar. 
Knappen skal fremstilles på en anden måde, da det er et gennem-
sigtigt felt, der ligger over hele banneret. Du får også repeteret at 
arbejde med scener, og du bliver præsenteret for lidt nyt Action-
Script.
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Opgave

Klikbart banner
Opgavebeskrivelse
I denne opgave skal du lave et klikbart banner. Brugeren skal 
kunne klikke hvorsomhelst og nårsomhelst på banneret og blive 
ledt til en webadresse. Banneret er opbygget i 3 scener, med en 
maske-effekt.

•	 Åbn en ny Flash File.
•	 Sæt størrelsen på Stage til 600 X 90 px. 
•	 Vælg Import - Import to Library.
•	 Åbn mappen banner fra kursusmaterialet, markér billedet ban-

ner og vælg Open.
•	 Træk billedet ind på Stage og navngiv laget baggrund, forlæng 

til 200 frames.
•	 Opret et nyt lag, kald det tekst1.
•	 Skriv første linie til teksten til scene 1, eller kopier teksten fra 

word dokumentet bannertekst, der ligger i mappen banner. 
Lad teksten fylde 200 frames.

•	 Opret et nyt lag, kald det maske1.
•	 Lav herpå en maske over 70 frames der kan åbne for teksten, 

(se evt. opgaven om masker).
•	 Opret et nyt lag, kald det tekst2.
•	 Skriv tekstlinie 2 i frame 71, og lav også et lag med maske til 

denne tekst. Lad maske2 gå til frame 150. 
•	

De sidste 60 frames skal være statiske. Dette gøres for at skabe 
lidt ophold i mellem de 3 scener, som for brugeren er de 3 tekstud-
sagn.

Scene 1

Scene 2

Scene 3
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Opgave

•	 Opret et nyt lag, kald det link, herpå skal knappen sidde.
•	 Vælg Insert > New Symbol. Vælg Button og kald den knap.
•	 Træk et rektangel på 600 x 90 pixel på knappens stage.
•	 Træk keyframet fra Up og hen til Hit. Du skal kun bruge en gen-

nemsigtig knap, der dækker hele banneret. 

•	 Vend tilbage til Stage og træk knappen ind på denne i laget link.
•	 Giv knappen Instance_Name: knap1_btn
•	 Opret et nyt lag, kald det actions.

ActionScript
Det er ikke muligt at genbruge navnet på knappen, selvom der er 
tale om forskellige scener. Ligeledes skal funktionen også navngi-
ves forskelligt. Det er kun nødvendigt at henvise til URL’en i første 
scene. Her er scriptet til scene 1.

•	 Indsæt scriptet i frame 1 i laget actions.
•	 Lav nu to scener mere på nøjagtig samme måde, blot med de 

nye tekster, samt med nye scripts. Den nemmeste måde er at 
vælge Duplicate Scene fra Scene paletten.

•	
Her er scriptet til scene 2, lav selv scriptet til scene 3.

Aflevér opgaven som aftalt med din underviser.

Klikbart banner
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Opgavebeskrivelse

Med afsæt i opgaven med navigation, skal du til slut lave en lidt 
mere spændende film. Du kan vælge at bruge nedenstående op-
læg, eller du kan selv finde på indholdet, følgende skal dog være 
indeholdt i filmen: 
Flere scener
Interaktivitet
Lyd
Masker
Animation
Scrollbar

Koen
Lav en lille film om en ko. Filmen består af 4 scener. Start med at 
tegne et storyboard hvor du beskriver indholdet af scenerne. Bil-
leder og lyden ligger i mappen »Koen«, her ligger også en swf film 
så du kan lade dig inspirere af. Du opfordes til at udbygge scener-
ne rent grafisk. Hvad med en sol, skyer, fugle, luftballon, kokasser 
og hvad de nu ellers har derude på landet...

Åbningsscene 
Sluk mobilen - nu starter filmen. Teksten vises ved hjælp af en 
maske.

Tæppet går til side
Tæppet trækkes fra og til syne kommer koen. Filmen stopper og 
brugeren skal nu vælge én af de tre knapper.

Selve filmen
Vift: Koen vifter med halen
Flyv: En bi flyver ind og stikker koen. Der skal lyde et AV når bien 
stikker.
Slut: Ved klik på knappen slut, trækkes tæppet for og filmen star-
ter forfra, dette er scene 4.

Animationen med halen samt bien laves som movieclips. 

Aflevér opgaven som aftalt med din underviser.

Afsluttende
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Fase Forklaring Navigation

Navigationsseddel

Åbn Flash, vælg symbolet ud for Actions 
Script 3.0

Sæt størrelse til 550 x 350 px

Importér billederne fra mappen seasons i 
kursusmaterialet

Navngiv det første lag foto

Træk billedet spring ind på Stage

Åbn paletten Scene og navngiv scenen 
spring

Opret et nyt lag, kald det knap

Tegn et gråt rektangel, denne bliver til en 
knap

Opert et nyt lag, kald det tekst. Skriv herpå 
teksten Spring. Placér teksten ovenpå 
knappen

Konvertér rektanglet til en Button (F8). 
Navngiv den knap

Markér tekst og knap og vælg group (ctrl+g)

Hold alttasten nede og træk tre dubletter 
med musen

Vælg ctrl+shift+g for at låse de tre knapper 
op igen

Skriv den rigtige tekst på de tre knapper

Vælg Window > Align. Markér alle 4 knap-
per. Klik på To Stage i Align paletten, Vælg 
derefter Align Bottom Edge.
Marker de 4 knapper uden teksten, og vælg 
Space evenly horizontally. 
Markér derefter de 4 tekstbokse og vælg 
igen Space evenly horizontally.
 
Duplikér scenen spring 3 gange og giv 
scenerne de rigtige navne

Giv hver knap et unikt navn

Programmér alle scener. Se opgaven

Åbn en ny Flash File

Definér Stage

Hent billeder

Navn

Placér billedet

Navn

Nyt lag

Knap

Tekst

Knap

Group

Duplikér

Ungroup

Skriv tekst

Justér

Flere scener

Navngiv knapperne

ActionScript

Styr scener
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Fase Forklaring Navigation

Navigationsseddel

Åbn Flash, vælg symbolet ud for Actions 
Script 3.0

Sæt størrelsen 

Lav indholdet af scene 1

Åbn paletten Scene og vælg Add Scene

Dobbeltklik på scenenavnet og omdøb

Åbn en ny Flash File

Definér Stage

Første scene

Ny scene

Navngiv

Flere scener
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Fase Forklaring Navigation

Navigationsseddel

Åbn Flash, vælg symbolet ud for Actions 
Script 3.0

Sæt størrelse til 550 x 350 px

Importér billederne fra mappen seasons i 
kursusmaterialet

Navngiv det første lag foto

Træk billedet spring ind på Stage

Åbn paletten Scene og navngiv scenen 
spring

Opret et nyt lag, kald det knap

Tegn et gråt rektangel, denne bliver til en 
knap

Opert et nyt lag, kald det tekst. Skriv herpå 
teksten Spring. Placér teksten ovenpå 
knappen

Konvertér rektanglet til en Button (F8). 
Navngiv den knap

Markér tekst og knap og vælg group (ctrl+g)

Hold alttasten nede og træk tre dubletter 
med musen

Vælg ctrl+shift+g for at låse de tre knapper 
op igen

Skriv den rigtige tekst på de tre knapper

Vælg Window > Align. Markér alle 4 knap-
per. Klik på To Stage i Align paletten, Vælg 
derefter Align Bottom Edge.
Marker de 4 knapper uden teksten, og vælg 
Space evenly horizontally. 
Markér derefter de 4 tekstbokse og vælg 
igen Space evenly horizontally.
 
Duplikér scenen spring 3 gange og giv 
scenerne de rigtige navne

Giv hver knap et unikt navn

Programmér alle scener. Se opgaven

Åbn en ny Flash File

Definér Stage

Hent billeder

Navn

Placér billedet

Navn

Nyt lag

Knap

Tekst

Knap

Group

Duplikér

Ungroup

Skriv tekst

Justér

Flere scener

Navngiv knapperne

ActionScript

Slideshow
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Fase Forklaring Navigation

Navigationsseddel

Åbn Flash, vælg symbolet ud for Actions 
Script 3.0

Sæt størrelse og baggrundsfarve

Tegn en firkant, rød Stroke, intet fyld

Dobbeltklik på stroken, konvertér til Mo-
vieclip med navnet indhold

Dobbeltklik på movieclippet for at komme 
til dets eget studie. Navngiv laget indhold. 
Indsæt frame i frame 4

Opret nyt lag, kald det grafik

Markér frame 2, indsæt Keyframe. Tegn en 
firkant. Indsæt Blank Keyframe i frame 3 
og tegn en cirkel. Indsæt Blank Keyframe i 
frame 4 og tegn en trekant

Opret nyt lag, kald det lables. Indsæt key-
frames i frame 2, 3 og 4

Frame 2 skal hedde firkant, frame 3 cirkel 
og frame 4 trekant

Vend tilbage til Stage. Giv den store firkant 
instance name: geometri_mc

Opret nyt lag, kald det knapper.

Tegn et rektangel, konvertér til Button med 
navnet knap

Duplikér knappen 2 gange og placér dem 
ovenover den store firkant

Giv knapperne instace names: firkant_btn, 
cirkel_btn og trekant_btn

Opret et nyt lag, kald det tekst. Skriv tekst-
erne til knapperne. Placér teksterne ovenpå 
knapperne

Opret nyt lag, kald det actions

Skriv ActionScriptet - se opgaven

Åbn en ny Flash File

Definér Stage

Tegn firkant

Konvertér

Redigér movieclippet

Nyt lag

Tegn elementer

Nyt lag

Navngiv lables

Navngiv movieclippet

Nyt lag

Knap

Duplikér knap

Navngiv knapper

Nyt lag

Nyt lag

ActionScript

Navigation
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Fase Forklaring Navigation

Navigationsseddel

Åbn Flash, vælg symbolet ud for Actions 
Script 3.0

Sæt størrelse og baggrundsfarve

Importér billederne fra mappen billedgalleri i 
kursusmaterialet

Træk billede 1 over på Stage. Konvertér 
billedet til Symbol/Grafic 

Markér frame 2 og indsæt et tomt keyframe 
(F7), træk billede 2 ind på Stage. konvertér 
igen til grafik og placér billedet i samme 
position som billede 1 ved hjælp af Align 
panelet. Fortsæt samme fremgangsmåde 
med de 4 sidste billeder

Opret 2 lag. Kald det ene knapper og det 
andet actions

Placér to knap-symboler (buttons) på laget 
du kaldte knapper.

Giv de to knapper navnene frem_btn og 
tilbage_btn

I laget actions frame 1 tilføjes ActionScript-
tet

Åbn en ny Flash File

Definér Stage

Hent billeder

billede 1

Placér billederne

Opret lag

Knapper

Instance_name

Scripting

Billedgalleri1
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Fase Forklaring Navigation

Navigationsseddel

Åbn Flash, vælg symbolet ud for Actions 
Script 3.0

Sæt størrelse og baggrundsfarve

Importér billederne fra mappen slide i kur-
susmaterialet

Opret 4 nye lag

Træk billederne ind på Stage, placér dem 
ved siden af hinanden, på hvert sit lag

Konvertér billederne til Movieclips

Forlæng lagene til 70 frames. Indsæt Key-
frames i frame 35 og 70

Lav Classic Tween på alle billederne

Markér frame 1 - slide1. Sæt Alpha til 0%. 
Markér frame 35, sæt Alpha til 100%, mar-
kér frame 70, sæt Alpha til 0%

Ryk de enkelte lags indhold på Timeline. 
Tilføj evt. flere lag med halvtransparente 
streger der bevæger sig henover billederne

Åbn en ny Flash File

Definér Stage

Hent billeder

Lag

Placér  billederne

Movieclips

Udvid filmen

Tween

Alpha

Dynamik

Slideshow
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Fase Forklaring Navigation

Navigationsseddel

Åbn Flash, vælg symbolet ud for Actions 
Script 3.0

Sæt størrelse og baggrundsfarve

Opret 2 lag

Skriv en tekst på laget signatur

Tegn en firkant uden ramme på laget ma-
ske. Firkanten skal være så stor, at den kan 
kan dække hele teksten

Indsæt en Keyframe i frame 40 (F6) på 
laget maske. I frame 1 placéres firkanten til 
venstre for teksten, uden for Stage. I frame 
40 placéres firkanten oven på teksten, så 
denne er helt dækket

Vælg Classic Motion Tween

Højreklik på laget masken og vælg Mask 
fra rullemenuen

Lås lag og maske op ved at klikke på hæn-
gelåsen ud for hvert lag

Indsæt en Stopaction i frame 40

Åbn en ny Flash File

Definér Stage

Lag

Tekst

Maske

Placering af firkanten

Bevægelse

Masken

Lås op

Stop

Masker
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Fase Forklaring Navigation

Scrollbar Navigationsseddel

Åbn mappen scroll fra kursusmaterialet, 
åbn filen tekst til scrollbar og kopier teksten

Behold default størrelsen på Stage

I properties vælges Dynamic Text samt 
udseeende af teksten

Træk en tekstboks på Stage

Højreklik på tekstboksen med Selection 
Tool

Indsæt den kopierede tekst i tekstboksen

Hent scrollbaren I menuen Window. Vælg 
Components > User Interfase. Vælg USI-
Scrollbar og træk scrollbaren ind på Stage

Placér scrollbaren på højre side af tekst-
boksen

Giv scrollbaren samme højde som tekstbok-
sen. Sæt målene i Properties

Markér tekstboksen og giv den navnet 
tekst_txt i feltet Instance Name i Properties

Markér scrollbaren og vælg Component 
Inspector Panel i Properties. I feltet til højre 
for scrollTargetName skriver du navnet du 
gav tekstboksen, i dette eksempel tekst_txt

Kopier en tekst

Åbn en Flash film

Foretag indstillinger

Opret tekstboks

Lås tekstboksen

Indsæt tekst

Indsæt scroolbaren

Fastgør scrollbaren

Tilret scrollbaren

Navngiv scrollbaren

Tilknyt scrollbaren
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Fase Forklaring Navigation

Navigationsseddel

Åbn filmen bang.fla fra mappen lyd i kursus-
materialet

Opret 1 nyt lag, kald det lyd

Vælg Window > Common Libraries > 
Sounds. Træk lydfilen xplosion Blast 
Large01.mp3 ind på Stage

Dobbeltklik på lydfilen i Library. Test 
forkellige komprimeringsgrader og 
formater.

Åbn filmen bang.fla

Lag

Hent lyd

Komprimér

Import af lyd
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Fase Forklaring Navigation

Navigationsseddel

Åbn Flash, vælg symbolet ud for Actions 
Script 3.0

Sæt størrelsen til 100x50 px

Fremstil 2 knapper eller hent  nogle forde-
finerede her: Window >Common Libraries 
>Bottons

Giv knapperne instance names: play _btn 
og stop_btn i Properties

Opret et nyt lag, kald det lyd

Træk lyden Foley Footstep Cowboy Boots 
Running Between Surfaces 01.mp3 i Win-
dow >Common Libraries >Sounds ind på 
Stage

Forlæng begge lag til 60 frames. Flyt lyden 
til frame 2

Opret et nyt lag, kald det actions

Åbn scriptvinduet og skriv ActionScriptet

Åbn en ny Flash File

Definér Stage

Knapper

Navngiv

Lag

Hent lyd

Forlæng og flyt

Lag

Programmér

Lydafspiller
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Fase Forklaring Navigation

Navigationsseddel

Åbn Flash, vælg symbolet ud for Actions 
Script 3.0

Sæt størrelse 

Importér billedet fra mappen banner i kur-
susmaterialet

Træk billedet over på Stage

Kald laget for baggrund

Forlæng filmen til 200 frames

Opret et nyt lag, kald det tekst1

Skriv eller kopier teksten til scene 1 linie 1

Opret et nyt lag, kald det maske1

Lav herpå en maske over 70 frames

Opret et nyt lag, kald det tekst2

Skriv tekstlinie 2 i frame 71, og lav også et 
lag med maske til denne tekst. Lad maske2 
gå til frame 150 

Opret et nyt lag, kald det link

Vælg Insert > New Symbol. Vælg Button og 
kald den knap. Træk et rektangel på 600 x 
90 pixel på knappens stage. Træk keyfra-
met fra Up og hen til Hit.

Vend tilbage til Stage og træk knappen ind 
på denne i laget link

Giv knappen Instance_Name: knap1_btn

Opret et nyt lag, kald det actions

Skriv scriptet til scene 1 (se opgaven)

Duplikér scene 1 to gange, og indsæt 
ActionScript

Åbn en ny Flash File

Definér Stage

Hent billeder

Billede1

Navngiv lag

Forlæng

Opret lag

Indsæt tekst

Opret lag

Maske

Opret lag

Indsæt tekst

Opret lag

Fremstil knap

Indsæt knap

Instance_name

Opret lag

Scripting

Duplikér scener

Klikbart banner
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